New Contributor

my google calendar doesn't sync to my iPhone

Hi community. I have my Google account set up on my iPhone. Emails sync across real time without any problem but the calendar does not. Are there settings that I need to change? This is a relatively new problem and I wonder if it is related to password changes - the last time I did this was a few weeks ago. If so, it would be useful to know the tips and tricks for making sure that all password changes reflect across to devices seamlessly.

Community Manager

Re: my google calendar doesn't sync to my iPhone

Hi Sel, 


Welcome to myTechCommunity! Thanks for posting!!


When changing your gmail password, you will be prompted to update your password on your iphone which will continue the sync.

Sometimes your calendar just needs to be refreshed.



Here is one thing you can try first, which I find works for me me if you click onto your calendar icon on your iphone and the bottom you will have listed "Today, Calendars, Inbox" If you select on calendars, just ensure that under gmail all gmail is ticked and that your rmit email address or if its your personal gmail account is ticked. The little trick is to then hold onto the page and flick it down, a spinning icon will appear and will refresh the calendar to most update to information, I find that new events I have added become visable on my calendar. 


Capture.PNG 1.PNG 



However if that doesn't work, another thing you may need to check is your iphone's fetch/push setting.. 

Go to settings > Mail, Contacts, Calendars 

Tap on Fech New Data 

Now, tap on the gmail account 

Tap on Fetch (if you want updates to show up automatically) or Manual (if you want to refresh things manually) 

Also, under Fetch New Data, scroll down to the fetch section and pick a time interval (15 mins, 30 mins or hourly) You can also pick manual. 




I hope this was helpful.. 


Happy Posting!!


Happy Posting!!!

New Contributor

Re: my google calendar doesn't sync to my iPhone

Thanks Yasmine, problem solved!