Moderator

 

 

   1. Tap the Settings icon from your apps and select Wifi

   2. Select the eduroam network from the list


   3. The Security type should be PEAP by default. Some models of Android devices may require setting the CA Certificate to
       Do not validate, otherwise leave as None.

        android-eduoram1.jpg

 
  4.  Under Identity enter your student or staff ID in the format: SXXXXXXX/eXXXXX@rmit.edu.au and your RMIT password
       for the Password field. Anonymous Identity should remain empty.

 

       android-eduroam2.jpg

 

   6. Tap Connect

 

   

Comments
Regular Visitor

So apparently as of March or April 2017, there's a new procedure to connect but I can't find the definitive announcement for changes (I thought I saw one; perhaps it was a popup window somewhere).

 

TTLS, PAP and no certificate didn't seem to work for me yesterday (2017-04-16) on Android.

 

What did work however were the macOS settings which I could see after I had connected (https://community.its.rmit.edu.au/t5/IT-Knowledge-Base/Connect-to-eduroam-using-macOS/bc-p/5706).

 

For eduroam they were:

EAP method: PEAP

Phase-2 authentication: MSCHAPV2

CA certificate: Do not validate

Identity: sXXXXXXX@rmit.edu.au (NOT sXXXXXXX@student.rmit.edu.au)

Anonymous identity: (blank)

Password: Your decent passphrase or password managed password

 

Can somebody confirm that these are the best correct settings to use? It seemed to be the only ones that worked for me.

Moderator

Hi @Raymond,

 

I too am using an Android-based device (Samsung Galaxy S6 on 6.0.1) and have been able to successfully connect to the eduroam network using the guide above (ie: TTLS and PAP setup).
You may have already tried forgetting the network entirely from your phone but if not, do try that first and re-connect.
There may be slight variations across Android devices (I've seen some that won't connect unless you also place the username in the Anonymous identity section, for example), but that's all you should need! =)

Regards,


Adam

Regular Visitor

Ah I tried it again tonight with your published settings and it worked. Android 7.1.2. Smiley Happy

New Visitor

I had to use setup suggested by Raymond to be able to connect to eduroam. I am running Android 7.1.1.

EAP method: PEAP

Phase-2 authentication: MSCHAPV2

Regular Visitor
I wonder if it's just the local network's authentication being temporarily down at certain points. As far as I understand, there's effectively no difference between TTLS and PEAP for the end user - they're just different options that both the network and our devices support. My biggest initial confusion was getting the username right and being unsure as to whether authentication had failed or was simply taking a long time.
Moderator

Hi guys,

 

I have seen eduroam take a little longer to authenticate (assuming all details are correct, that is), but should ultimately get the device on the network.

As a side note, just connected up from scratch using:
Username: eXXXXX@rmit.edu.au
Password: <RMIT password>
EAP method: PEAP
Phase 2 Auth: None

 

So maybe let the device have a few seconds longer to authenticate. 

 

Regards,

Adam

New Visitor

Still works in July 2019. @Raymond 

 

EAP method: PEAP

Phase-2 authentication: MSCHAPV2

CA certificate: Do not validate

Identity: sXXXXXXX@rmit.edu.au (NOT sXXXXXXX@student.rmit.edu.au)

Anonymous identity: (blank)

Password: Your set password OR p(birthyear)(birthmonth)(birthday)!