Connecting to eduroam is only necessary when off campus at another institution. When on campus,
   connect to the RMIT-University wifi network.
   1. Click on the wifi icon  MacWifiIcon.jpg and select the eduroam network to connect



2. When prompted, enter your student/staff ID in the format sXXXXXXX@rmit.edu.au/eXXXXX@rmit.edu.au along with your RMIT password and click Join.


Screen Shot 2017-04-06 at 12.25.05 pm.png

Once you click Join, the wireless icon should turn black and you should now have a working internet connection.


NOTE: If you have connected to eduroam on your Mac before, you may have the deprecated eduroam profile, which you will need to remove first. The following instructions explain how to do this:


1. Open System Preferences (/Applications/System Preferences)

2. Select Profiles



Screen Shot 2017-04-07 at 9.31.50 am.png

  1. Select Eduroam from the list of User Profiles, and then click on the minus sign sign at the bottom-left.

Screen Shot 2017-04-07 at 9.35.03 am.png

  1. Click on the wifi icon  MacWifiIcon.jpg and select the eduroam network to connect.
  2. When prompted, enter your student/staff ID in the format sXXXXXXX/eXXXXX@rmit.edu.au along with your RMIT password and click Join.


Regular Visitor

I think I saw an announcement somewhere about the previous certificate procedure changing but can't seem to find it anymore. Anyway:


Step 2 in the first section suggests sXXXXXXX@student.rmit.edu.au/eXXXXX@rmit.edu.au, but the the updated part at the bottom lists sXXXXXXX/eXXXXX@rmit.edu.au (without the student.edu.au) for student accounts too.


I tried both yesterday (2017-04-16) at a non-RMIT campus and it appears the latter (id@rmit.edu.au) remains the correct format. I can confirm that I had to remove my old certificate/profile in macOS.


Hi @Raymond


You are correct: the format for the username should be sXXXXXXX@rmit.edu.au (not the email format of @student.rmit.edu.au). The previous must have been a typo.

This has been updated. Thanks for catching this one!



New Visitor

Hi.  I'm at Melb Uni Law Library and unable to login to eduroam with my rmit info.  Can you help?



New Visitor

It finally worked!



Hi @Ahutch0,


I am on a OSx 10.14 and cannot see the "profiles" setting and cannot log in to eduroam either. Can you give me information what should be done?

I was connected until I had to change my password.


Thank you.